Fiber issues at Fillmore
Incident Report for FRUITION
Resolved
Router firmware upgrade resolved latency issue. Primary VPN service has been restored.
Posted almost 2 years ago. Oct 19, 2015 - 07:31 MDT
Monitoring
We're experiencing connectivity issues with our primary fiber connection.
Posted almost 2 years ago. Oct 16, 2015 - 14:15 MDT