Outage Denver
Incident Report for FRUITION
Resolved
This incident has been resolved.
Posted 9 months ago. Mar 03, 2017 - 10:46 MST
Investigating
We're experiencing a major outage at our Denver datacenter. Updates to come.
Posted 9 months ago. Feb 23, 2017 - 16:03 MST