Emails from hosted office365 accounts will not reach any user@fruition.net
Incident Report for FRUITION
Resolved
This incident has been resolved.
Posted over 2 years ago. Mar 23, 2015 - 20:26 MDT
Identified
Due to a planned email migration emails from hosted office365 email accounts to any @fruition.net email account will bounce
Posted over 2 years ago. Mar 20, 2015 - 09:48 MDT