Fruition-Fillmore - VPN Issues
Incident Report for FRUITION
Resolved
The VPN issue is fixed.
Posted almost 3 years ago. Nov 10, 2014 - 09:44 MST
Monitoring
The main office VPN is currently down. We are working with the hardware manufacture on a fix.
Posted almost 3 years ago. Nov 10, 2014 - 09:00 MST